APK Blog - Virtualization, Services, Datacenter, Infrastructure

انتشار نسخه VMware vSphere 6.7 U2c

نسخه‌ای جدید VMware به تازگی منتشر گردید که در حقیقت شامل آخرین به‌روزرسانی برای VMware vSphere  است که بیشتر این به‌روزرسانی امنیتی می‌باشد. هیچ خصوصیت جدیدی در این نسخه افزوده نشده‌است. همان‌گونه که گمان می‌رود، این آخرین نسخه‌ی Patch پیش از معرفی vSphere 6.7 U3، که اکنون در مراحل تست و بررسی به سر می برد، می‌باشد. این نسخه‌ی تنها برای vCenter و VCSA می‌باشد.

Build Number های این محصولات به ترتیب برای vCenter Server 6.7  و برایvCenter Server Appliance 6.7  عبارت است از 14070457. این محصولات شامل رفع نقص‌های امنیتی برای سیستم عامل Photon  برای VCSA و همچنین آخرین پچ‌های امنیتی برای ESXi Hypervisor می‌باشد.

در صورتی که شخص بخواهد زیر ساخت مجازی خود را از نسخه‌های پیشین vSphere به آخرین VMware vSphere 6.7 U2c ارتقا دهد، باید این نکته را در نظر بگیرد که برخی پیکربندی‌ها پشتیبانی نمی‌گردند. برای مثال، در رابطه با ارتقا از vSphere 6.5 U3 لازم است موارد زیر را در نظر داشته باشید:

الزامات بروزرسانی VMware vSphere 6.7 

ارتقا و انتقالات از vCenter Server 6.5 Update 3 به vCenter Server 6.7 Update 2c پشتیبانی نمی‌گردند. vCenter Server 6.5 Update 3 حاوی رفع نقص‌های امنیتی و کدی است که در نسخه‌ی vCenter Server 6.7 Update 2c موجود نیست و ممکن است منجر به کاهش سطح امنیت گردد.

شرکت APK (امن پایه ریزان کارن) دارای مجرب ترین تیم طراحی شبکه و نخستین شرکت دانش محور در اجرای پروژه های انفورماتیکی کشور

ارتقا از vCenter Server 6.7 Update 1a به 6.7 Update 2c پشتیبانی نمی‌گردد. ابتدا باید به vCenter Server 6.7 Update 1b یا 6.7 Update 2 ارتقا داد، سپس سیستم را به 6.7 Update 2c بروزرسانی (Patch) کنید.

اینها تنها دو مورد از الزامات این بروزرسانی می باشد و همان‌گونه که مشاهده می کنید، بهتر است که مستندات آن را پیش از ارتقا، مورد بررسی قرار داد.

برخی از مشکلات برطرف‌شده

  • زمانی که یک Template ماشین مجازی که توسط Content Library میزبانی می‌شود را از یک Libraryی که به چندین مشترک سرویس می‌دهد، انتشار می‌دهید ، اگر حین ساخت یک ESXi Host مقصد مشخص نگردد، عملیات ناموفق خواهد بود و یک خطا مشابه زیر دریافت خواهید کرد:

« An invalid argument \”spec.location.host\” was specified »

این مشکل در این نسخه با افزوده شدن SelectCompatibleHostActivity برطرف گردیده‌است. این روش در صورتی که Hostی مشخص نشده باشد، یک ESXi Host سازگار را از کلاستر یا  از Resource Pool انتخاب می‌کند.

  • کرنل سیستم عاملPhoton بروزرسانی گردید و به نسخه‌ی 4.4.182 به‌روزرسانی شده‌ است تا مشکلات امنیتی را با شناسه‌های CVE-2019-11477 و CVE-2019-11478 و نیز CVE-2019-11479 برطرف نماید.

روش ارتقای VCSA

دو روش جهت ارتقای VCSA موجود می باشد. در صورتی که VCSA ارتباط اینترنتی داشته باشد، این امر بسیار ساده است. باید از طریق واسط کاربری VAMI و پورت 5480 به‌عنوان Root متصل گردید و بر منوی Update و سپس بر دکمه‌ی Stage and Install کلیک نمود.

انتشار نسخه VMware vSphere 6.7 U2c

راه دوم، دستی می‌باشد:

دانلود و نصب

می‌توان این Patch را با مراجعه به VMware Patch Download Center و انتخاب VC از منوی Drop-Down با عنوان Search by Product، دانلود نمود.

  1. باید فایل VMware-vCenter-Server-Appliance-6.7.0.32000-14070457-patch-FP.iso را به درایو DVD یا CDی vCenter Server Appliance ضمیمه نمود.
  2. باید به Appliance Shell به‌عنوان Root وارد شد و دستورات ذیل را اجرا نمود:
  3. جهت Stage نمودن ISO:

software-packages stage –iso

  1. جهت مشاهده‌ی محتوای Stageشده:

software-packages list –staged

  1. جهت نصب RPMهای Stageشده:

software-packages install –staged

اشتراک ایمیل